
Lights and Cameras
 
 
Learning Objectives
After completing this chapter, you will be able to:
• Work with standard lights
• Work with photometric lights
• Use the Place Highlight tool
• Work with Camera tools
• Understand camera viewport controls
• Work with the Align Camera tool
 
INTRODUCTION
In 3ds Max, lights are used to illuminate a scene and thereby making it more realistic. They are also
used to create the sources of illumination such as street lights, flashlights, and so on. The two main
categories of lights available in 3ds max are: Standard and Photometric. In these categories,
different types of lights are available. You need to select one or more lights based on the requirement
of a scene. The Photometric lights provide more realistic lighting effects but they are more complex
than the Standard lights.
 
STANDARD LIGHTS
In 3ds Max, the Standard lights are objects that simulate lights. You can create eight types of Standard
lights in 3ds Max. To create a light in a scene, choose Create > Lights in the Command Panel. By
default, the Photometric option will be displayed in the drop-downlist below the Lights button.
Select the Standard option from the drop-down list. You can choose one of the tools available in
the Object Type rollout to create different types of lights in the viewport, refer to Figure 13-1. When
you choose a tool from the Object Type rollout, various rollouts will be displayed. These rollouts
are used to modify the parameters of lights. The tools in the Object Typerollout are discussed next.

Figure 13-1 The tools to create standard lights in the Object Type rollout

 
Omni
Menu bar: Create > Lights > Standard Lights
> Omni



Command Panel: Create > Lights > Standard
> Object Type rollout > Omni
 
The Omni tool is used to create an omni light in the viewport. An omni light is a single point in space
that projects the rays uniformly in all directions. To create an omni light, choose the Omni tool; the
Name and Color, General Parameters, Intensity/Color/Attenuation, Advanced Effects, Shadow
Parameters, and Shadow Map Params rollouts will be displayed in the Modify panel. Move the
cursor in the viewport; the shape of the cursor will change. Click in the viewport to place the light.
You can continue clicking in the viewport to add more than one light. Next, right-click in the viewport
to exit the command. To modify the parameters of a light, select the light and choose the Modify tab in
the Command Panel; various rollouts will be displayed. These rollouts are used to modify the
parameters of the selected light. The most commonly used rollouts are discussed next.
 
Name and Color Rollout
This rollout is used to modify the name of the selected light by entering the new name in the text box.
You can also modify the color of the selected light using the color swatch. But, this will only change
the color of the geometry of the light in the viewport and will not affect the color of the light being
emitted.
 
General Parameters Rollout
The options in this rollout are used to set the parameters of the selected light, refer to Figure 13-2. In
the Light Type area of this rollout, the On check box is selected by default. As a result, the light will
illuminate the scene, refer to Figures 13-3 and

Figure 13-2 The General Parameters rollout
13-4. If you clear the On check box, then the light will not illuminate the scene. The drop-down list
on the right side of the On check box is used to define the type of light. By default, the Omni option is
selected in this drop-down list. You can also select the Directional or the Spot option to convert the
omni light into directional or spot light. The Targeted check box is activated only if the Directional
or Spot Light option is selected from the drop-down list. On selecting any of these options, a spinner
will be displayed next to the Targeted check box. The value in the spinner is used to specify the
distance of the target from the light. You will learn about the spot and directional lights later in this
chapter.

 

Figure 13-3 The scene without any light



Figure 13-4 The scene with the omni lights applied
 

In the Shadows area, select the On check box. As a result, the light will cast the shadow of the object
on rendering. You can also preview the shadows in the realistic viewports. The procedure for
viewing the shadows in the shaded viewports is discussed next.
 

 
By default, the Realistic shading is displayed in the Perspective viewport. In the Realistic shading
type, shadows are displayed by default in the viewport. When you click on it, a flyout will be
displayed. First, choose the Shaded option and then choose the Lighting and Shadows option from
the flyout; a cascading menu will be displayed, as shown in Figure 13-5. Note that in this menu the
Shadows option is chosen by default.
 
Next, when you place a light in the viewport, select it and right-click on it; a quad menu will be
displayed, as shown in Figure 13-6. Choose the Cast Shadows option; the shadows of the object will
be displayed on rendering. Figure 13-7 shows the shadow of the object displayed in the Perspective
viewport with the Realistic shading type.
 

Figure 13-5 The cascading menu displayed in the viewport

Figure 13-6 The quad menu displayed
in the viewport

Figure 13-7 The shadow of the object with the Realistic shading type



 
 

To display the shadows for more than one lights in the scene, choose Tools > Light Lister from the
menu bar; the Light Lister window will be displayed, as shown in Figure 13-8. This dialog box
will display the description of all lights used in the scene. Now, select the check box(es) in the
Shadows column; the shadows of the light corresponding to the selected check box(es) will be
displayed in the viewport.

Figure 13-8 The Light Lister window
 

The drop-down list next to the Shadows check box in the Light Lister window is used to select the
types of shadow for the light.

The Use Global Settings check box is located next to the On check box. This check box is used to
cast shadows of the light as per the global settings. The drop-down list below the check boxes is
used to specify the shadow map that the renderer will use while generating the shadows of the light.
By default, the Shadow Map is selected in this drop-down list. It specifies the map which the
renderer will use, while generating the shadows of the light.

 
The Exclude button is used to select the objects in the scene that you do not want to get affected by

the light at rendering. By default, the light affects all objects in the scene. To exclude or include an
object from the effect of the light, choose the Exclude button; the Exclude/Include dialog box will
be displayed, as shown in Figure 13-9. The Scene Objects area on the left side of this dialog box
displays the list of all objects in the current scene. On the top right of this dialog box, there are two
radio buttons namely, Include and Exclude. By default, the Exclude radio button is selected. As a
result, the objects will be excluded from the effect of light. To do so, select the objects that you
want to exclude from the list displayed in the Scene Objects area. Then, choose the right arrow
button;

the selected object will be excluded from the selected light. Also, they will be displayed in the area
on the right side of this dialog box. Similarly, to include the excluded objects again, select the
excluded objects from the area on the right side, and choose the left arrow button; the selected
objects will be included. Next, choose the OK button.

 



Figure 13-9 The Exclude/Include dialog box
 

Intensity/Color/Attenuation Rollout
The options in this rollout are used to set the color, intensity, and attenuation of the light, refer to
Figure 13-10. The decrease in the intensity of light with distance is called attenuation.The Multiplier
spinner in this rollout is used to set the intensity of the light. By default, the value in this spinner is
1.0. You can increase or decrease the value to increase or decrease the brightness of the light. Choose
the color swatch on the right side of the Multiplier spinner; the Color Selector: Light Color dialog
box will be displayed. Select the color of the light and choose the OK button to assign a new color to
the light. The areas in the Intensity/Color/Attenuation rollout are discussed next.
 

Note
If you increase the value in the Multiplier spinner to a very high extent, the scene will burned out.
So, it is recommended that you increase the value gradually as required for the scene.

Decay Area
The options in this area are used to reduce the intensity of the light over the distance. The Type
drop-down list is used to define the type of decay that will be used for the selected light. By
default, the None option is selected and therefore no decay is applied to the light, refer to Figure
13-11. In this case, if you use the options in the Far Attenuation area, then the decay will be
applied to the light according to the values in the Start and End spinners. Select the Inverse option
in the Type drop-down list to apply the light with intensity varying inversely with respect to
distance, as shown in Figure 13-12. Select the Inverse Square option to apply the light intensity
that varies with square inverse proportion with respect to distance, as shown in Figure 13-13. The
Inverse and Inverse Square options use some mathematical equations to apply the decay effect on
the light. When you select the Inverse or the Inverse Square option, the gizmo will be displayed in
the viewport for the selected light to define the distance from where the decay starts. Set the value
in the Start spinner of the Decay area to specify the distance from where the decay starts. On
selecting the Show check box, a gizmo will be displayed even if the light is not selected.



Figure 13-10 The Intensity/Color/Attenuation rollout

Figure 13-11 The effect of light on selecting the None option
 

Figure 13-12 The effect of light on selecting the Inverse option

Figure 13-13 The effect of light on selecting the Inverse Square option
 

Near Attenuation Area
The Near Attenuation area is used to set the distance at which the light begins to fade in. Select
the Use check box to enable the near attenuation for the selected light; a gizmo will be displayed in
the viewport to define the near attenuation. Select the Show check box to display the gizmo in the
viewport even if the light is not selected. Set the value in the Start spinner to define the distance at
which the light begins to fade in. Set the value in the End spinner to define the distance at which the
light reaches its maximum value that is 100%.
 
Far Attenuation Area
The Far Attenuation area is used to set the distance at which the light begins to fade out. Select the
Use check box to enable the far attenuation for the selected light; a gizmo will be displayed in the
viewport to define the far attenuation. Select the Show check box to display the gizmo in the
viewport even if the light is not selected. Set the value in the Start spinner to define the distance at
which the light begins to fade out. Set the value in the End spinner to define the distance at which
the light reaches its minimum value that is zero.
 

Advanced Effects Rollout
The options in this rollout are used to set the effects of light on surfaces, refer to
Figure 13-14. This rollout is also used to provide settings for the projector lights. The
areas in this rollout are discussed next.

Figure 13-14 The Advanced Effects rollout
 



Affect Surfaces Area
The Contrast spinner in this area is used to adjust the contrast between different areas of the object
that are affected by the diffuse and ambient lights. By default, the value in this spinner is 0, which
provides the normal contrast. Set the value in the Soften Diff. Edge spinner to soften the transition
between the ambient and the diffuse areas. The Diffuse and Specular check boxes are selected by
default and are used to affect the diffuse and specular light areas, respectively. If you clear the
Diffuse or Specular check box, the light will not affect the diffuse or specular property of the
surface. On selecting the Ambient Only check box, the light will affect only the ambient area of the
illumination.
 
Projector Map Area
This area is used to make a light act as a projector. To do so, select the light in the viewport and
choose the Modify tab in the Command Panel. Now, in the Projector Map area of the Advanced
Effects rollout, select the Map check box to enable the projector effect. Next, choose the None
button; the Material/Map Browser dialog box will be displayed. Choose the map type from the
Material/Map Browser dialog box; the name of the material will be displayed on the None button
and the selected map will be projected in the scene at rendering.
 

Note
You can adjust the settings of the projector map in the Material Editor dialog box.

Shadow Parameters Rollout
The options in this rollout are used to control the properties of the shadow, refer to Figure 13-15.
Choose the color swatch from the Object Shadows area to modify the color of the shadow. The
Dens. spinner is used to adjust the density of the shadow. By default, the value in this spinner is 1.0.
On increasing the value, the shadow will become denser or darker. Select the Map check box to
assign a map to the shadow. To do so, choose the map button labeled as None and assign a map as
discussed earlier; the selected map will be displayed in the shadow, as shown in Figure 13-16. Select
the Light Affects Shadow Color check box to blend the color of the light with the shadow.
 
The Atmosphere Shadows area in the Shadow Parameters rollout is used to enable the different
atmospheric effects, such as volume fog, to cast shadows in a scene. The On check box is used to cast
the shadow by using the atmospheric effect, when the light passes through them. The Opacity spinner
is used to control the opacity of the shadows cast by the atmospheric effect. The Color Amount
spinner is used to adjust the blending of the atmosphere’s color and the shadow color.
 

Figure 13-15 The Shadow Parameters rollout



Figure 13-16 A dent map used as a shadow map
 
Atmospheres & Effects Rollout
The options in this rollout are used to assign special effects such as fog, lighting effects, and so on to
the environment on rendering, refer to Figures 13-17 and 13-18. To assign a special effect to the
scene, select the light in the viewport and expand the Atmospheres & Effects rollout. Now, choose
the Add button; the Add Atmosphere or Effect dialog box will be displayed, as shown in Figure 13-
19. Select the effect from this dialog box to add it to the light selected in the viewport and choose the
OK button; the selected effect will be displayed in the Atmospheres & Effects rollout. Next, select
the effect from the Atmospheres & Effects rollout and choose the Setup button; the Environment
and Effects dialog box will be displayed, refer to Figure 13-20. You can set the parameters of the
selected effect using the corresponding rollout in this dialog box. If you want to delete an effect from
the scene, select the effect in the Atmospheres & Effects rollout and choose the Delete button.
 

Note
To view the hidden rollouts of the selected effect in the Environment and Effects dialog box, hover
the cursor over the dialog box until the shape of the cursor changes to the hand icon. Next, drag
the cursor up or down to see the hidden rollouts.
 

Figure 13-17 The Atmospheres & Effects rollout

Figure 13-18 The lens effect applied to the omni light
 
 

Figure 13-19 The Add Atmosphere or Effect dialog box



Figure 13-20 The Environment and Effects dialog box

 
 

Target Spot
Menu bar: Create > Lights > Standard Lights > Target Spotlight
Command Panel: Create > Lights > Standard > Object Type rollout > Target Spot
The Target Spot tool is used to create the spot lights. A spot light projects the rays in a particular
direction from a source, refer to Figure 13-21. The target spot light also has a target spot to locate the
target, refer to Figure 13-22.

 
To create a target spot light, choose the Target Spot tool; the Name and Color, General
Parameters, Intensity/Color/Attenuation, Spotlight Parameters, Advanced Effects, Shadow
Parameters, and Shadow Map Params rollouts will be displayed. Now, move the cursor over the
viewport; the shape of the cursor will change. Press and hold the left mouse button to specify the
starting point of the light and drag the cursor to locate the target of the light. Release the left mouse
button; a target spot light will be created. Next, you can modify the parameters of the light using
various rollouts displayed in the Command Panel. To exit the light command, right-click in the
viewport. The most commonly used rollouts are discussed next.
 

Note
The Name and Color, General Parameters, Intensity/Color/Attenuation, Advanced Effects,
Shadow Parameters, and Atmospheric Effects rollouts are same for all types of lights as
discussed in the omni light.



 
Figure 13-21 The effect of the target spot light with the Volume Light effect

Figure 13-22 The target spot light
 
Spotlight Parameters Rollout
The options in the Light Cone area of this rollout are used to set the effects of the target spotlight,
refer to Figure 13-23. Select the Show Cone check box to view the cone in the viewport even if the
light is not selected. Select the Overshoot check box to project the light in all directions, but the
shadows of the light will fall within the distance specified in the Falloff/Field spinner. When you
select the Overshoot check box, the Hotspot/Beam spinner will be deactivated.
TheHotspot/Beam spinner is used to set the angle of the cone of the target spot light in degrees. The
hotspot is the part of the light cone that provides the most acute illumination. Set the value in
theFalloff/Field spinner to adjust the angle of the falloff of the light. The falloff is the area at which
the light intensity falls to zero.

Figure 13-23 The Spotlight Parameters rollout
 

By default, the Circle radio button is selected. It provides a circular shape to the hotspot and falloff
areas. Select the Rectangle radio button to provide a rectangular shape to the hotspot and falloff
areas. On selecting the Rectangle radio button, the Aspect spinner and Bitmap Fit button gets
activated. Set the value in the Aspect spinner to adjust the aspect ratio. The aspect ratio is the ratio of
the width to the height. You need to set the aspect ratio to match a particular bitmap. Choose the
Bitmap Fit button; the Select Image File to Fit dialog box will be displayed. Select the bitmap
image and choose the Open button; 3ds Max will adjust the aspect ratio in the Aspect spinner
according to the image selected in the Select Image File to Fit dialog box.
 
Free Spot
Menu bar: Create > Lights > Standard Lights > Free Spotlight
Command Panel: Create > Lights > Standard > Object Type rollout > Free Spot
The Free Spot tool is similar to the Target Spot tool but a free spot light does not have any target,
refer to Figure 13-24. All the rollouts used to adjust the free spot light are the same as those
discussed in the target spot light.



Figure 13-24 The free spot light
 

Target Direct
Menu bar: Create > Lights > Standard Lights > Target Direct
Command Panel: Create > Lights > Standard > Object Type rollout > Target Direct
The Target Direct tool is used to create direct lights. A direct light projects the rays in a particular
direction from a source. But it projects the parallel rays instead of a cone, refer to Figures 13-25 and
13-26. The target direct light simulates the sunlight.

Figure 13-25 The effect of the target direct light

Figure 13-26 The target direct light
 
To create a target direct light, choose the Target Direct tool; the Name and Color, General
Parameters, Intensity/Color/Attenuation, Directional Parameters, Advanced Effects, Shadow
Parameters, and Shadow Map Params rollouts will be displayed. Move the cursor over the
viewport; the shape of the cursor will change. Next, press and hold the left mouse button to specify
the starting point of the light and drag the mouse to

Figure 13-27 The Directional Parameters rollout

specify the target of the light. Release the left mouse button; the target direct light will be displayed in
viewports. Next, you can modify the parameters of the light using various rollouts in the Command
Panel. Most of the rollouts are same as discussed earlier in this chapter, except the Directional
Parameters rollout. The options in the Directional Parameters rollout are same as those discussed
in the Spotlight Parameters rollout of the target spot light, refer to Figure 13-27.
 



Free Direct
Menu bar: Create > Lights > Standard Lights > Free Direct
Command Panel: Create > Lights > Standard > Object Type rollout > Free Direct
The Free Direct tool is also used to create the direct light but unlike the Target direct light, this light
does not have a target, refer to Figure 13-28. All the rollouts to adjust the free direct light are same as
those discussed in the target spot light.

Figure 13-28 The free direct light
 

Skylight
Menu bar: Create > Lights > Standard Lights > Skylight
Command Panel: Create > Lights > Standard > Object Type rollout > Skylight
The Skylight tool is used to create daylights. The best effect of the skylight comes when you use it
with the Light Tracer. To create a skylight, choose the Skylight tool; the Name and Color and
Skylight Parameters rollouts will be displayed. Now, move the cursor over the viewport; the shape
of the cursor will change. Click in the viewport; the light will be displayed in the viewport. Figure
13-29 shows the skylight displayed in the Perspective viewport. Now, choose Rendering > Light
Tracer from the menu bar; the Render Setup: Default Scanline Renderer dialog box will be
displayed. In the Advanced Lighting tab of this dialog box, set the parameters as required and then
choose the Render button; the effect of the light will be displayed, refer to Figure 13-30. The Name
and Color rollout is similar to other tools as discussed earlier. The Skylight Parameters rollout is
discussed next.

Figure 13-29 The skylight

Figure 13-30 The effect of the skylight
 
Skylight Parameters Rollout
The On check box is selected by default in this rollout, which enables the skylight to be used in the
scene, refer to Figure 13-31. Set the value in the Multiplier spinner to define the intensity of the light.
The areas in this rollout are discussed next.



Figure 13-31 The Skylight Parameters rollout
 

Sky Color Area
By default, the Sky Color radio button is selected. Choose the color swatch on the right side of the
Sky Color radio button to select the color for the skylight. The Map check box is selected by
default. It is used to insert a map along with the light that affects the skylight. By default, the value
in the spinner on the right side of the Map check box is 100.0. If you decrease the value, the color
of the map will be mixed with the sky color. Choose the Map button labeled as None; the
Material/Map Browser dialog box will be displayed. Select the desired map and choose the OK
button to display the map along with the light.

 
Select the Use Scene Environment radio button to use the color that you have set in the
Environment and Effects dialog box for the skylight.
 
Render Area
The parameters in this area are deactivated if the Light Tracer or Radiosity plugin is used. Select
the Cast Shadows check box to project a shadow with the light. Set the value in the Rays per
Sample spinner to define the number of rays in the skylight projecting in the scene. Set the value in
the Ray Bias spinner to define the closest distance at which an object can project the shadows in
the scene.
 

mr Area Omni
Menu bar: Create > Lights > Standard Lights > mr Area Omni
Command Panel: Create > Lights > Standard > Object Type rollout > mr Area Omni
The mr Area Omni tool is used with the mental ray renderer. It is used to create an area omni light,
refer to Figure 13-32. If you use the area omni light and render the scene using the default scanline
renderer, then its effects will be similar to the standard omni light. To view the best effect of the mr
area omni light, you need to change the renderer.

Figure 13-32 The effect of the area omni light
 



To render the scene with the NVIDIA mental ray renderer, choose the Render Setup tool from the
Main Toolbar; the Render Setup: Default Scanline Renderer dialog box will be displayed. The
Common tab is chosen by default in this dialog box. Now, scroll down in the dialog box and expand
the Assign Renderer rollout. Choose the Choose Renderer button on the right side of the
Production text box, as shown in Figure 13-33; the Choose Renderer dialog box will be displayed,
as shown in Figure 13-34. Select the NVIDIA mental ray option and choose the OK button; the
Default Scanline Renderer text will be replaced with the NVIDIA mental ray text in the
Production text box. Choose the Render button and close the Render Setup dialog box. Now, the
scene will be rendered using the mental ray renderer.

Figure 13-33 The Choose Renderer button highlighted in the Assign Renderer rollout

Figure 13-34 The Choose Renderer dialog box
 

Note
To get the best results with the mental ray rendering, choose the mr Area Omni tool and choose
the Modify tab in the Command Panel. Next, set the parameters in the Indirect Illumination and
mental ray Light Shader rollouts.

To create an area omni light, choose the mr Area Omni tool; the Name and Color, General
Parameters, Intensity/Color/Attenuation, Advanced Effects, Shadow Parameters, Ray Traced
Shadow Params, and Area Light Parameters rollouts will be displayed in the Modify panel. Now,
move the cursor over the viewport; the shape of the cursor will change. Click in the viewport; the
light will be displayed in the viewport. Next, you can modify the parameters of the light using various
rollouts in the Command Panel. Most of the rollouts are same as discussed earlier in the omni light.
The Area Light Parameters rollout is discussed next.
 
Area Light Parameters Rollout
In this rollout, the On check box is selected by default, refer to Figure 13-35. As a result, light effects
are displayed on rendering. Select the Show Icon in Renderer check box to display a shape at the
location of the area light on rendering. To view the shape on rendering, you need to render the scene
using the NVIDIA mental ray renderer. The Type drop-down list is used to select the type of shape



for the area light. By default, the Sphere option is selected. Select the Cylinder option to display
a cylindrical shape. Set the value in the Radius spinner to set the radius of the shape displayed. Note
that when you select Cylinder in the Typedrop-down list, the Height spinner is also activated. Set the
value in this spinner to define the height of the cylindrical shape displayed. The Samples area in this
rollout is discussed next.

Figure 13-35 The Area Light Parameters rollout

 
Samples Area
The options in this area are used to set the quality of the shadow projected by the area omni light.
Set the value in the U spinner to specify the number of subdivisions along the radius, or the height
of the sphere or cylinder. Set the value in the V spinner to specify the number of angular
subdivisions in the shape.

 

Note
You need to use the NVIDIA mental ray renderer to view the effects of the parameters set in the
Area Light Parameters rollout.
 
mr Area Spot
Menu bar: Create > Lights > Standard Lights > mr Area Spot
Command Panel: Create > Lights > Standard > Object Type rollout > mr Area Spot
The mr Area Spot tool is used to create an area spot light, as shown in Figure 13-36. It is same as the
mr Area Omni light and is used with the NVIDIA mental ray renderer. The only difference is that it
projects the rays in a particular direction from the source.
 
To create an area spot light, choose the mr Area Spot tool; the Name and Color, General
Parameters, Intensity/Color/Attenuation, Spotlight Parameters, Advanced Effects, Shadow
Parameters, Ray Traced Shadow Params, and Area Light Parameters rollouts will be displayed.
Move the cursor over the viewport; the shape of the cursor will change. Now, press and hold the left
mouse button to specify the location of the light, drag the cursor to locate the target of the light, and
release the left mouse button; the light will be displayed in the viewports. You can modify the
parameters of the light using various rollouts displayed in the Command Panel. Most of the rollouts
have already been discussed. The Area Light Parameters rollout for the area spot light is discussed
next.
 
Area Light Parameters Rollout



The options in this rollout are same as discussed for the mr Area Omni tool, refer to Figure 13-37. In
the Type drop-down list, the Rectangle shape is selected by default. It is used to display the area
spot light in a rectangular shape. Specify the height and width in the Height and Width spinners,
respectively. Select the Disc shape in the Type drop-down list to display the light in circular shape;
the Radius spinner will get activated. Set the value in this spinner to specify the radius of the shape.

Figure 13-36 The effect of the area spot light

Figure 13-37 The Area Light Parameters rollout
 

PHOTOMETRIC LIGHTS
The photometric lights are used to add realistic light effects to the scenes. The photometric lights use
the light energy values to calculate the lights accurately as they are in the real world.
There are three types of photometric lights in 3ds max. To create a photometric light in a scene,
choose Create > Lights in the Command Panel; the Photometric light will
be displayed by default in the drop-down list below the Lights button. Also, various tools to create
photometric lights will be displayed in the Object Type rollout. These tools are Target Light, Free
Light, and mr Sky Portal, refer to Figure 13-38. Choose one of these tools and create the light in the
viewport. If you choose the Target Light or Free Light tool, the Photometric Light
Creation message box will be displayed, asking if you want to use the
Logarithmic Exposure Control, refer to Figure 13-39. Choose the Yes button in this message box.
When you choose a tool from the Object Type rollout, various rollouts will be displayed to modify
the parameters of the corresponding light.

Figure 13-38 Various tools to create Photometric lights
 

The Name and Color, General Parameters, Shadow Parameters, Advanced Effects, and
Atmospheres & Effects rollouts for photometric lights are same as discussed in the standard lights.



The Intensity/Color/Attenuation, Templates, and Shape/Area Shadows rollouts for the target light
and the free light are discussed next.
 
Templates Rollout
The options in this rollout are used to specify preset light types such as 40W bulb, Street 400W
Lamp, and so on, refer to Figure 13-40. To do so, select a light in the viewport and click on the down
arrow at the bottom of the Templates rollout; a drop-down list will be displayed, as shown in Figure
13-41. Select the required light type from the drop-down list. You will notice a change in the light
effect in the viewport. Also, the description of the selected light will be displayed in the text area just
above the drop-down list.

Figure 13-39 The Photometric Light Creation message box
 

Figure 13-40 The Templates rollout

Figure 13-41 The drop-down list displayed to select the type of light
 
 
Tip: 1.To get more familiar with the photometric lights, place them in the scenes and try out
various options in the rollouts.
 
2. To get the best effect of the photometric lights, render the scene using Light Tracer or Radiosity
from the Advanced Lighting tab in the Render Setup dialog box.

 
Intensity/Color/Attenuation Rollout
The options in this rollout are used to set the intensity, color, dimness, and attenuation of the light,
refer to Figure 13-42. The areas in this rollout are discussed next.

Color Area
The drop-down list on the top of this area displays different common lamp specifications. By default,
the D65 Illuminant (Reference) option is selected in the drop-down list. Select the other options; the



color in the color swatch on the right side of the Kelvin radio button will change according to the
selection in this drop-down list. Select the Kelvin radio button to specify the color of the light by
setting the color temperature in the spinner on the right of this radio button. The value in this spinner
is in kelvin unit. As you change the value (temperature) of this spinner, the color in the color swatch
will change accordingly. Choose the Filter Color color swatch to specify the color of the color filter.

Figure 13-42 The Intensity/Color/Attenuation rollout

 
Intensity Area
The options in this area specify the intensity of the light. By default, the cd radio button is selected
that measures the intensity of the light in candela unit. Select the lm radio button to measure the
intensity of the light in lumen unit. Select the lx at radio button to measure the intensity in lux unit. Set
the values in the spinners below these radio buttons to specify the intensity of the light.

 
Dimming Area
The options in this area are used to set the intensity by dimming the light. The resulting intensity is set
by the value specified in the Resulting Intensity spinner. By default, this spinner is not active. Select
the Resulting Intensity check box. Next, enter a value in the spinner. A value of 100 indicates that the
light will be displayed with its full intensity. Select the Incandescent lamp color shift when
dimming check box to simulate an incandescent light as the light gets dimmed.

 
Shape/Area Shadows Rollout
The options in this rollout are used to specify a light shape that generates the shadows, refer to Figure
13-43. The controls in this rollout work with the NVIDIA mental ray renderer. To get a similar effect
in the scanline renderer, you can select Area Shadows from the GeneralParameters rollout,
since photometric area shadows are not calculated in the scanline renderer. The areas in this rollout
are discussed next.

Figure 13-43 The Shape/Area Shadows rollout



 
Emit light from (Shape) Area
The drop-down list on the top in this area is used to select the shape for generating the shadows. On
selecting an option from the drop-down list (except the Point option), the dimension controls related
to the selected option will be displayed at the bottom of this area. You can set the dimensions in the
respective spinners to modify the shape. Also, the Shadows Samples drop-down list will be
displayed in the Rendering area.
 
 

Note
If you choose the Point shape from the drop-down list in the Emit light from (Shape) area, then
the Shadows Samples drop-down list will not be available in the Rendering area.
 
Rendering Area
Select the Light Shape Visible in Rendering check box to view the light shape at rendering. The
different options in the Shadows Samples drop-down list are used to set the quality of the shadows of
the light.
 
DEFAULT LIGHTS
When there are no lights in the scene, the scene is illuminated or rendered with the default lights.
There are two invisible default lights in the scene, one is above and to the left of the scene, and the
other is below and to the right. You can control these lights using the options in the Viewport
Configuration dialog box. To invoke this dialog box, click on the General viewport label in any of
the viewports; a shortcut menu will be displayed. Choose Configure Viewports from the shortcut
menu; the Viewport Configuration dialog box will be displayed, as shown in Figure 13-44. By
default, the Visual Style & Appearance tab is chosen in this dialog box. In this tab, the Scene Lights
radio button is selected in the Lighting and Shadows area. As a result, only scene lights are used in
the scene.

Figure 13-44 The Viewport Configuration dialog box
 



Note
If no light exists in the scene, the default lighting is used automatically even when the Scene
Lights radio button is selected in the Lighting and Shadows area of the Viewport Configuration
dialog box.

 
Sometimes, the light which we create in the scene does not illuminate the object properly in a scene.
In that case, you can use the default lighting to evenly illuminate the scene. To do so, choose Create >
Lights > Standard Lights > Add Default Lights to Scene from the menu bar; the Add Default
Lights to Scene dialog box will be displayed, as shown in Figure 13-45. In this dialog box, the Add
Default Key Light and Add Default Fill Light check boxes are selected, by default. Choose the OK
button; the default key light and fill light will be added to the scene. Both these lights will be Omni
lights.

Figure 13-45 The Add Default Lights to Scene dialog box
 
PLACE HIGHLIGHT TOOL
Menu bar: Tools > Align > Place Highlight
Main Toolbar: Align flyout > Place Highlight
Keyboard: CTRL + H

The Place Highlight tool is used to align a light with an object to position its highlight accurately.
Before performing the alignment, make sure that the object with highlight is visible in the viewport.
Now, select the light in the viewport and choose the Place Highlight tool; the shape of the cursor will
change. Next, move the cursor over the object on which you want to place the highlight; a selection
cursor will be displayed, as shown in Figure 13-46. Click on it; the light will be aligned accordingly
and the highlight will be repositioned, refer to Figure 13-47.

Figure 13-46 The selection cursor displayed after invoking the Place Highlight tool

Figure 13-47 The light aligned as per the selection of the face of the object
 
CAMERAS



In 3ds Max, the cameras are used to adjust a particular view in a scene. These cameras act as the still
image or video cameras in the real world. There are two types of cameras in 3ds Max, namely Target
and Free. The target camera has two parts, the target camera and a target object, as shown in Figure
13-48. It displays the view according to the position of the target object. You can move the target
object and the target camera independently. The free camera does not have any target object, as
shown in Figure 13-49. It displays the view in the direction of the camera. You can use the free
camera to perform the walkthrough animation.

Figure 13-48 The target camera

Figure 13-49 The free camera
Creating a Target Camera
Menu bar: Create > Cameras > Target Camera
Command Panel: Create > Cameras > Standard > Object Type rollout > Target
To create a target camera, choose Create > Cameras in the Command

Figure 13-50 The Object Type rollout with tools to create cameras

Panel; the Standard option will be displayed in the drop-down list below the Cameras button. You
can use the tools in the Object Type rollout to create cameras, refer to Figure 13-50. Choose the
Target tool; the Name and Color, Parameters, and Depth of Field Parameters rollouts will be
displayed in the Command Panel. Next, move the cursor over the viewport; the shape of cursor will
change. Press and hold the left mouse button to specify the location of the camera, drag the cursor to
specify the target of the camera, and release the left mouse button; the target camera will be displayed
in the viewports. You can modify the parameters of the camera using the rollouts displayed in the
Command Panel. Next, right-click in the viewport to exit the command.

 
To display the camera view in the viewport, move the cursor over the POV viewport label and click
on it; a flyout will be displayed. Choose the Cameras option; a cascading menu will be displayed, as
shown in Figure 13-51. Choose the Camera001 option; the current viewport label will be replaced
by the Camera001 label. Alternatively, you can press the C key to display the camera view. The
Parameters rollout is used to modify the parameters of the camera and is discussed next.
 



Parameters Rollout
To modify the parameters of the camera, make sure that the camera is selected in the viewport. Next,
choose the Modify tab in the Command Panel; the Parameters rollout will be displayed, as shown
in Figure 13-52.
 
The Lens spinner in this rollout is used to specify the focal length of the camera in millimeters. The
focal length is the distance between the camera lens and its focus. Set the value in the FOV spinner to
specify the field of view of the camera in degrees. The field of view (FOV) determines the area that
the camera can view in the viewport. The Stock Lenses area in this rollout is discussed next.

 

Figure 13-51 The cascading menu displayed on choosing
the Cameras option

Figure 13-52 Partial view of the Parameters rollout
 

Stock Lenses Area
Choose one of the buttons in this area to set the focal length of the camera in millimeters. On
choosing a button in this area, the value in the Lens and FOV spinners will also change
automatically.

 
The Type drop-down list is used to set the type of camera in the viewport. The Target Camera is
selected by default in this drop-down list. Select the Free Camera option to use the free camera.
Select the Show Cone check box to view the FOV cone in all viewports, even if the camera is not
selected. Select the Show Horizon check box to view the horizon line displayed in dark gray color in
the Camera viewport.
 
Creating a Free Camera
Menu bar: Create > Cameras > Free Camera
Command Panel: Create > Cameras > Standard > Object Type rollout > Free



To create a free camera, choose Create > Cameras in the Command Panel; the Standard option
will be displayed in the drop-down list. Choose the Free tool from the Object Type rollout; the
Name and Color, Parameters, and Depth of Field Parameters rollouts will be displayed. Move the
cursor over the viewport; the shape of the cursor will change. Now, click in the viewport; the camera
will be displayed in the viewports. You can modify the parameters of the camera using the rollouts
displayed in the Command Panel. The options in these rollouts are the same as those discussed in the
target camera.
 
ALIGN CAMERA TOOL
Menu bar: Tools > Align > Align Camera
Main Toolbar: Align flyout > Align Camera

The Align Camera tool is used to align a camera normal to a selected surface. To align a camera,
select it in the viewport and then choose the Align Camera tool; the shape of the cursor will change.
Next, move the cursor over the surface of the object; a selection cursor will be displayed, as shown
in Figure 13-53. Select the face; the camera will be aligned accordingly, refer to Figures 13-54, 13-
55, and 13-56.

Figure 13-53 The cursor displayed on the object to get the proper alignment

Figure 13-54 The Camera viewport before alignment
 

Figure 13-55 The new position of the camera after using the Align Camera tool

Figure 13-56 The Camera viewport after using the Align Camera tool
 

 



TUTORIALS
Before starting the tutorials, you need to download the c13_3dsmax_2015_tut.zip file from
www.cadcim.com. The path of the file is as follows: Textbooks > Animation and Visual Effects > 3ds
Max > Autodesk 3ds Max 2015: A comprehensive Guide
 
Extract the contents of the zipped file and save them in the Documents folder.
Tutorial 1
In this tutorial, you will create a scene, as shown in Figure 13-57, by using the lights, materials and
maps. (Expected time: 30 min)

Figure 13-57 The scene to be created
 

The following steps are required to complete this tutorial:
 
a. Create the project folder.
b. Download the file.
c. Create a plane for water surface.
d. Create the camera.
e. Create the background.
f. Assign the maps and materials.
g. Create the lights.
h. Save and render the scene.
 
Creating the Project Folder
1. Create a new project folder with the name c13_tut1 at \Documents\3dsmax2015 and then save the

file with the name c13tut1, as discussed in Tutorial 1 of Chapter 2.
 
2. Open the Windows Explorer and then browse to the c13_3dsmax_2015_tut folder and copy the

sky_1.jpg file from this folder to \Documents\3dsmax2015\c13_tut1\sceneassets\images.
 
Creating a Plane for Water Surface
In this section, you will create a plane for the water surface by using the Plane tool.
 
1. Activate the Top viewport and choose Create > Geometry in the Command Panel; the Standard

Primitives option is displayed in the drop-down list below the Geometry button. Now, choose the
Plane tool from the Object Type rollout.



 
2. Create a plane in the Top viewport and set the values in the Parameters rollout as follows:
Length: 273.604 Width: 297.462
 
3. In the Name and Color rollout, rename the plane as water surface.
 
4. Choose the Zoom Extents All tool to display water surface in the viewports, as shown in Figure

13-58.

Creating the Camera
In this section, you will add a camera to the scene by using the Free camera tool.
 
1. Activate the Front viewport. Choose Create > Cameras in the Command Panel; the Standard

option is displayed in the drop-down list.
 

2. Choose the Free tool from the Object Type rollout to create a free camera for adjusting the view.
In the Front viewport, click on the middle of water surface; the free camera is displayed in the
viewports. It is automatically named as Camera001.

 

Note
If you use more than one camera in a scene, then it is recommended that you modify the name of
the cameras depending on the view you have adjusted.

Figure 13-58 A plane created for the water surface in viewports
 
3. Right-click anywhere in the viewport to exit the command.
 
4. Align Camera001 in all viewports by using the Select and Move and Select and Rotate tools,

refer to Figure 13-59. Next, activate the Perspective viewport and press the C key; the Perspective
label is replaced by Camera001 label and the view is changed according to the position of the
camera, refer to Figure 13-59.

 
 



Figure 13-59 Alignment of Camera001 in viewports
 

Creating the Background
In this section, you will create a background of the scene by using the Sphere tool.
 
1. Activate the Top viewport and choose Create > Geometry in the Command Panel; the Standard

Primitives option is displayed in the drop-down list below the Geometry button. Now, choose the
Sphere tool from the Object Type rollout.

 
2. Move the cursor at the center of water surface and create a sphere in the Top viewport. Set the

values in the Parameters rollout as follows:
 
Radius: 72.0 Hemisphere: 0.74
 
3. In the Name and Color rollout, modify the name of the sphere as background.
 
4. Make sure that background is selected in the Top viewport. Next, right-click on the Select and

Uniform Scale tool; the Scale Transform Type-In dialog box is displayed. In the Offset: Screen
area of the dialog box, set the value 260 in the % spinner; background is scaled, as shown in
Figure 13-60. Close this dialog box.

Figure 13-60 The background after scaling
 

5. Make sure that background is selected and choose the Modify tab in the Command Panel. Select
the Normal modifier from the Modifier List drop-down list; the rollouts are displayed in the
Modify panel. In the Parameters rollout of the Normal modifier, make sure that the Flip Normals
check box is selected.

 



6. Choose the Select and Move tool and align background and Camera001 in viewports, as shown
in Figure 13-61.

Figure 13-61 Camera001 and background aligned in viewports
 
Assigning Maps and Materials
Next, you need to assign the maps and materials to the background and water surface.
 
1. Select water surface in any viewport and choose the Compact Material Editor tool; the Material

Editor dialog box is displayed.
First, you will create the material for water surface in the Material Editor dialog box.
 
2. Make sure the 01-Default sample slot is selected. Modify its name in the Material Name text box

to water surface material.
 
3. Choose the Material Type button that is currently labeled as Standard; the Material/Map

Browser dialog box is displayed. Select the Raytrace material from the Materials > Standard
rollout and choose the OK button; the Standard material is replaced by the Raytrace material. In
the Raytrace Basic Parameters rollout, make sure that the Phong shader is selected in the
Shading drop-down list.

 
4. Choose the Diffuse color swatch; the Color Selector: Diffuse dialog box is displayed. Select the

black color and choose the OK button to close the dialog box.
 
5. Choose the Reflect color swatch; the Color Selector: Reflect dialog box is displayed. Enter

values in the Red, Green, and Blue spinners as follows:
 
Red: 139 Green: 139 Blue: 139
 
Now, choose the OK button to close this dialog box.
 
6. In the Raytrace Basic Parameters rollout, select the Bump check box and choose the Bump

button labeled as None to assign a map to it; the Material/Map Browser dialog box is displayed.
Select the Noise map from the Maps > Standard rollout and choose the OK button; the Noise map



is displayed as the sub-material.
 
7. In the Noise Parameters rollout, set the values as follows:
 
Select the Fractal radio button.
 
Size: 5.0 Low: 1.0
 
8. Choose the Go to Parent tool to go back to the parent level. Alternatively, you can select water

surface material from the Material Name drop-down list.
 
9. Expand the Maps rollout and select the Reflect check box to make it available for the material.

Choose the Reflect map button labeled as None; the Material/Map Browser dialog box is
displayed. Select the Falloff map and choose the OK button; the Falloff map is displayed as the
sub-material. Use the default settings and choose the Go to Parent tool to go back to the parent
level; the None label is replaced by Map X (Falloff).

 
10. Make sure that water surface is selected in the viewport and choose the Assign Material to

Selection button; water surface material is assigned to the water surface in the viewport.
 
Next, you need to create the material for background.
 
11. Select the 02-Default sample slot and modify its name as background material in the Material

Name drop-down list. In the Shader Basic Parameters rollout, make sure that the Blinn shader is
selected in the drop-down list.

 
Next, you need to assign a map to the selected sample slot.
 
12. In the Blinn Basic Parameters rollout, choose the Diffuse map button on the right side of the

Diffuse color swatch; the Material/Map Browser dialog box is displayed. Select the Bitmap map
from the Maps > Standard rollout and choose the OK button; the Select Bitmap Image File dialog
box is displayed. As the project folder is already set, the images folder is displayed in the Look in
drop-down list of this dialog box. Select the file sky_1.jpg and choose the Open button; the
selected image is displayed in the background material sample slot.

 
13. Make sure that background is selected in the viewport and then choose the Assign Material to

Selection button; the background material is assigned to background in the viewport. Close the
Material Editor dialog box.

 
Next, you will apply the UVW Map modifier to background to align the map properly.
 
14. Choose the Modify tab in the Command Panel and select the UVW Map modifier from the

Modifier List drop-down list; the UVW Map is displayed in the modifier stack. The Parameters



rollout is displayed below the modifier stack.
 
15. In the Parameters rollout, set the values as follows:

Mapping area
Select the Box radio button.
 
Length: -1.374 Width: 93.147 Height: 31.408
 
Alignment area
Make sure that the Z radio button is selected.

 
16. Render Camera001 viewport using the Render Production tool; you will notice that the scene is

not visible properly, as shown in Figure 13-62. Therefore, you need to create the lights to view the
scene clearly.

 
Creating Lights
In this section, you will create lights by using the Omni tool.
 
1. Activate the Top viewport. Choose Create > Lights in the Command Panel; the Photometric

option is displayed in the drop-down list below the Lights button. Choose the Standard option
from the drop-down list.

 

Figure 13-62 The scene after rendering
 

2. Choose the Omni tool from the Object Type rollout in the Command Panel and click in the Top
viewport; the omni light is displayed in the viewports. It is automatically named as Omni001.

 
3. Choose the Select and Move tool and align Omni001 in the viewports, as shown in Figure 13-63.
 
4. Create one more omni light at the center of background in the Top viewport. It is automatically

named as Omni002. Now, align Omni002 in all viewports, as shown in Figure 13-64.



 
Next, you need to modify Omni002 light to create the sun effect.

 
5. Make sure that Omni002 light is selected and then choose the Modify tab in the Command Panel;

the rollouts to modify the light are displayed in the modify panel.
 

6. Expand the Atmospheres & Effects rollout and choose the Add button; the Add Atmosphere or
Effect dialog box is displayed. Select the Lens Effects option and then choose the OK button; the
Lens Effects option is displayed in the text area of the Atmospheres & Effects rollout.

 
Next, you need to modify the parameters of Lens Effects.
 

Figure 13-63 Alignment of Omni001 in the viewports
 

Figure 13-64 Alignment of Omni002 in the viewports
 

7. Select Lens Effects in the Atmospheres & Effects rollout and choose the Setup button; the
Environment and Effects dialog box is displayed. By default, the Effects tab is chosen in the
Environment and Effects dialog box.

 
8. In the Effects rollout, make sure the Lens Effects option is selected under the Effects area. Select

the Glow effect and choose the right arrow button in the Lens Effects Parameters rollout; the
Glow effect is displayed in the list available on the right side, as shown in Figure 13-65. Also, the
Glow Element rollout is displayed at the bottom of the Environment and Effects dialog box to



modify the parameters of the Glow effect.

Figure 13-65 The Lens Effects Parameters rollout
 

Note
1. To view all rollouts, you need to scroll inside the dialog box.
 
2. You can view the effects of the Lens Effects option only after rendering.
 
9. In the Glow Element rollout, set the value 20.0 in the Size spinner. Use the default values for other

options.
 
10. In the Lens Effects Parameters rollout, select the Ray effect and choose the right arrow button;

the Ray effect is displayed in the text area available on the right side. Also, the Ray Element
rollout is displayed at the bottom of the Environment and Effects dialog box to modify the
parameters of the Ray effect.

 
11. In the Ray Element rollout, set the values in the spinners as follows:
 
Size: 50.0 Num: 20
 
12. Close the Environment and Effects dialog box.
 
Saving and Rendering the Scene
 
1. Choose Save from the Application menu. Next, activate the Camera001 viewport.
 
2. Choose the Render Production tool; the Rendered Frame window is displayed showing the final

output of the scene at one frame, as shown in Figure 13-66.
 
3. Close the Rendered Frame window.



Figure 13-66 The final output of the scene

 
Tutorial 2
In this tutorial, you will illuminate a room by using the Omni and Target Direct tools, as shown in
Figure 13-67. (Expected time: 60 min)
The following steps are required to complete this tutorial:
 
a. Create the project folder.
b. Create the floor of room.
c. Create the walls of room.
d. Create the camera.
e. Create the roof of room.
f. Create the window of room.
g. Create the POP design of room.
h. Apply maps and materials to objects.
i. Create lights.
j. Create the background.
k. Save and render the scene.

Figure 13-67 The illuminated room
 
Creating the Project Folder
Create a new project folder with the name c13_tut2 at \Documents\3dsmax2015 and then save the
file with the name c13tut2, as discussed in Tutorial 1 of Chapter 2.



 
Creating the Floor of Room
In this section, you will create a floor for the room by using the Plane tool.
 
1. Activate the Top viewport and choose Create > Geometry in the Command Panel; the Standard

Primitives option is displayed in the drop-down list below the Geometry button. Now, choose the
Plane tool from the Object Type rollout.

 
2. Create a plane in the Top viewport and set the values in the Parameters rollout as follows:
Length: 867.0 Width: 600.0
 
3. In the Name and Color rollout, modify the name of the plane to floor.
 
4. Choose the Zoom Extents All tool to display the entire floor in viewports.
 
Creating the Walls of Room
In this section, you will create walls for the room by using the Wall tool.
 
1. Activate the Top viewport. Choose Create > Geometry in the Command Panel; the Standard

Primitives option is displayed by default in the drop-down list. Select the AEC Extended option
from the list and choose the Wall tool from the Object Type rollout.

 
2. In the Parameters rollout, set the values as follows:
 
Width: 5.0 Height: 300.0
 
3. In the Top viewport, create a closed wall as discussed earlier, as shown in Figure 13-68. It is

automatically named as Wall001. Choose the Zoom Extents All tool.

Figure 13-68 The Wall001 geometry created in viewports
 

Creating Camera
In this section, you will create a camera using the Free camera tool to adjust the view.
 



1. Activate the Front viewport and choose Create > Cameras in the Command Panel; the Standard
option is displayed in the drop-down list. Now, choose the Free tool from the Object Type
rollout.

 
2. Click at the middle point on Wall001; the free camera is displayed in all viewports. Now, right-

click anywhere in the viewport to exit the command. The free camera is automatically named as
Camera001.

 
3. Make sure that Camera001 is selected. Choose the Modify tab in the Command Panel. In the

Parameters rollout, set the value 73.0 in the FOV spinner.
 
4. Activate the Perspective viewport and press the C key to view the Camera viewport; the

Perspective label is replaced with the Camera001 label. Also, the view is changed based on the
position of the camera. Choose the Select and Move tool and align Camera001 in all viewports to
display the view properly, refer to Figure 13-69.

Figure 13-69 Alignment of Camera001 in viewports
 
Creating the Roof of Room
In this section, you will create the roof of room by using the Plane tool.
 
1. Activate the Top viewport and choose the Plane tool from Create > Geometry > Standard

Primitives > Object Type rollout.
 
2. Create a plane in the Top viewport and set the values in the Parameters rollout as follows:
 
Length: 867.0 Width: 600.0
 
3. In the Name and Color rollout, modify the name of the plane to roof.
 
4. Align roof at the top of Wall001 using the Select and Move tool, refer to Figure 13-70.

 
Creating the Window of Room



In this section, you will create a window of room by using the Box and Boolean tools.
 
1. Create a box in the Top viewport and modify its dimensions in the Parameters rollout as follows:
 
Length: 165.569 Width: 20.0 Height: 195.984

 
2. Align the box with Wall001 in the viewports, as shown in Figure 13-71.

Figure 13-70 The roof geometry aligned at the top of Wall001 in viewports
 

Figure 13-71 Alignment of box with Wall001 in viewports
 
Next, you need to perform the boolean operation on Wall001 to create a hole for the window.
3. Select Wall001 in the Top viewport. Choose Create > Geometry in the Command Panel. Select

the Compound Objects option from the drop-down list displayed below the Geometry button.
Now, choose the Boolean tool from the Object Type rollout.

 
4. In the Parameters rollout, make sure that the Subtraction(A-B) radio button is selected in the

Operation area.
5. Choose the Pick Operand B button in the Pick Boolean rollout. Next, move the cursor over the

box that you have created and then click on it; a hole is created in Wall001, as shown in Figure 13-
72. Right-click in the viewport to exit the Boolean command.



Figure 13-72 A hole created in Wall001
 
Next, you need to create another box to create the window.

 
6. Create another box in the Top viewport and modify its dimensions in the Parameters rollout as

follows:
 
Length: 165.569 Width: 2.0 Height: 195.984
Length Segs: 5 Width Segs: 1 Height Segs: 5
 
7. Modify the name of the box to window and color to black. Also, align it in all viewports to cover

the hole in Wall001, as shown in Figure 13-73.
 

Next, you need to apply the Lattice modifier to window.
 

Figure 13-73 Alignment of window in viewports
 

8. Make sure that window is selected and then choose the Modify tab in the Command Panel. Next,
select the Lattice modifier from the Modifier List drop-down list; the segments and edges of
window are converted into wireframes.

 
9. In the Parameters rollout of the Lattice modifier, set the values as follows:
 



Geometry area
Select the Struts Only from Edges radio button.

Struts area
Radius: 1.0
Use the default values for other options.
 
The window geometry is displayed, as shown in Figure 13-74.
 
Creating the POP Design of Room
In this section, you will create the POP design to decorate room.
 
1. Create a box in the Top viewport. In the Parameters rollout, set the values in the spinners as

follows:
 
Length: 5.0 Width: 210.581 Height: 33.843
Length Segs: 1 Width Segs: 1 Height Segs: 7
 
2. Name the box as design01.

Figure 13-74 The window geometry after applying the Lattice modifier
 

Next, you need to modify the design01 at the sub-object level.
 
3. Make sure that design01 is selected and choose the Display tab in the Command Panel. In the

Hide rollout, choose the Hide Unselected button; all unselected objects are hidden in the
viewports.

 
4. Activate the Camera001 viewport and press the P key to display the Perspective viewport.
5. Choose the Zoom Extents All tool to zoom into design01.
 
6. Select design01 and convert it into an editable mesh object; the sub-object levels of design01 are

displayed in the modifier stack.
 



7. Choose the Zoom tool and zoom into design01 to its maximum extent, as shown in Figure 13-75.
 
8. Choose the Maximize Viewport Toggle tool to maximize the Perspective viewport.
 
9. In the Selection rollout, choose the Edge button to activate the Edge sub-object level. Select the

six inner edges of design01 by holding the CTRL key in the Perspective viewport, as shown in
Figure 13-76.

 
10. In the Edit Geometry rollout, set the value 1 in the Chamfer spinner and press ENTER; the

selected edges are chamfered, as shown in Figure 13-77.

Figure 13-75 The design01 geometry zoomed to its maximum extent in the Perspective viewport

Figure 13-76 The inner edges selected in design01
 

11. In the Selection rollout, choose the Polygon button to activate the Polygon sub-object level.
Select the polygon at the bottom of design01, as shown in Figure 13-78.

Figure 13-77 The selected edges after chamfering

Figure 13-78 The polygon selected to be extruded
 
12. In the Edit Geometry rollout, enter the value 2.0 in the Extrude spinner to extrude the polygon.

Next, select every odd polygon one by one from the first polygon and enter the values in multiples
of 2 such as 4, 6, 8 and so on in the respective Extrude spinners, refer to Figure 13-79. Select the
Polygon sub-object level in the Selection rollout to disable it.

 



13. Choose the Maximize Viewport Toggle tool to view the four viewports; design01 is displayed in
the viewports.

 
14. Choose the Display tab in the Command Panel and then choose the Unhide All button in the Hide

rollout; all objects are displayed in the viewports.
 

15. Activate the Perspective viewport and press the C key to view the Camera001 viewport. Now,
choose the Zoom Extents All tool to view all objects in the viewports.

 
16. Align design01 with a portion of Wall001 in the viewports, refer to Figure 13-80. You can adjust

the size of design01 using the tools in the Select and Scale flyout in the Main Toolbar.

Figure 13-79 The design01 displayed after extruding the alternate polygons
 

Figure 13-80 Alignment of design01 in viewports
 

Note
To align design01 properly, you can use the Zoom Extent All Selected tool.
 
17. Create five copies of design01; they are automatically named as design002, design003,

design004, design005, and design006. Align all designs at the joining point of Wall001 and roof,
as shown in Figure 13-81. You need to adjust the size of all designs using the Select and Scale tool
accordingly. Also, you need to modify the corners at the Vertex sub-object level.



Figure 13-81 Alignment of all designs at the joining point of the Wall001 and roof
 
Applying Maps and Materials
In this section, you will apply materials and maps to wall, roof, floor, and Pop design geometries.
 
1. Select Wall001 from the Scene Explorer and choose Rendering > Material Editor > Compact

Material Editor from the menu bar; the Material Editor dialog box is displayed.
 
Next, you need to create the material for Wall001 in the Material Editor dialog box.
 
2. Select the 01-Default sample slot if it is not already selected, and then modify its name in the

Material Name drop-down list to wall material.
 
3. Choose the Material Type button that is currently labeled as Standard; the Material/Map

Browser dialog box is displayed. Select the Architectural material from Materials > Standard
rollout and choose the OK button; the Standard material is replaced by the Architectural material.
Also, various rollouts are displayed in the Material Editor dialog box to modify the Architectural
material.

 
4. In the Templates rollout, select the Paint Semi-gloss option from the drop-down list. In the

Physical Qualities rollout, choose the Diffuse Color color swatch; the Color Selector: Diffuse
dialog box is displayed. Set the values in the Red, Green, and Blue spinners as follows:

Red: 251 Green: 239 Blue: 191
 
Now, choose the OK button.

 
5. Make sure that Wall001 is selected in the viewport and then choose the Assign Material to

Selection button; the wall material is assigned to Wall001.
 
Next, you need to create a material for floor.
 
6. Select the 02-Default sample slot and modify its name in the Material Name text box to floor

material. In the Shader Basic Parameters rollout, make sure that the Blinn shader is selected in



the drop-down list.
 
Next, you need to assign a map.
 
7. In the Blinn Basic Parameters rollout, choose the Diffuse map button on the right side of the

Diffuse color swatch; the Material/Map Browser dialog box is displayed. Select the Bitmap map
from the Maps > Standard rollout and choose the OK button; the Select Bitmap Image File dialog
box is displayed. As the project folder is already set, the images folder is displayed in the Look in
drop-down list of this dialog box. Select the file Finishes.Masonry Flooring Marble.Beige-
Grid.jpg and choose the Open button; the selected image is displayed in the selected sample slot.
Also, the rollouts are displayed to modify the coordinates of the assigned map.

 
8. In the Coordinates rollout, set the value 4 in the U Tiling and V Tiling spinners. Next, choose the

Go to Parent button to go back to the parent level.
 
9. Expand the Maps rollout and then select the Reflection check box to make it available for the

material. Choose the Reflection map button labeled as None; the Material/Map Browser dialog
box is displayed. Select the Raytrace map from the Maps > Standard rollout and choose the OK
button; the Raytrace map is displayed as the sub-material. Use the default settings and then choose
the Go to Parent button to go back to the parent level; the None label is replaced by Map#x
(Raytrace). Next, set the value 5 in the Reflection spinner.

 
10. Select floor from the Scene Explorer and then choose the Assign Material to Selection button;

the floor material is assigned to floor. Choose the Show Shaded Material in Viewport button to
display the floor material on floor in the viewport.

 
Next, you will assign a material to roof.
 
11. Select the 03-Default sample slot and modify its name in the Material Name text box as roof

material.
 
12. In the Shader Basic Parameters rollout, select the 2-Sided check box. Next, you need to assign a

map to the selected sample slot.
 
13. In the Blinn Basic Parameters rollout, choose the Diffuse map button on the right side of the

Diffuse color swatch; the Material/Map Browser dialog box is displayed. Select the Bitmap map
and choose the OK button; the Select Bitmap Image File dialog box is displayed. Select the file
Concrete.Cast-In-Place.Flat.Brown.Grey.jpg and then choose the Open button; the selected image
is displayed in the selected sample slot. Also, the rollouts are displayed to modify the coordinates
of the assigned map.

 
14. In the Coordinates rollout, set the value 2 in both the U Tiling and V Tiling spinners. Next,

choose the Go to Parent button to go back to the parent level.



 
15. Make sure that roof is selected and then choose the Assign Material to Selection button; the roof

material is assigned to the roof in the viewport. Choose the Show Shaded Material in Viewport
button to display the roof material on the roof in the viewport.

 
Next, you will assign the material to the POP designs.
 
16. Select all designs simultaneously in the viewport using the Select by Name tool, and then group

them as design.
 
17. Select the 04-Default sample slot in the Material Editor dialog box and modify its name in the

Material Name text box to design material.
 
18. In the Blinn Basic Parameters rollout, choose the Diffuse color swatch; the Color Selector:

Diffuse Color dialog box is displayed. Enter the values in the Red, Green, and Blue spinners as
given below and then choose the OK button.

 
Red: 146 Green: 68 Blue: 5
19. Make sure the group design is selected in the viewport and then choose the Assign Material to

Selection button; the design material is assigned to design. Also, choose the Show Shaded
Material in Viewport button to display the design material on design in the viewport.

 
20. Close the Material Editor dialog box.
 
Next, you need to add lights to the scene to illuminate it.
 
Creating Lights
In this section, you will create lights by using the Omni and Target Direct tools.
 
1. Activate the Top viewport. Choose Create > Lights in the Command Panel and choose the

Standard option from the drop-down list. Next, choose the Omni tool from the Object Type
rollout. Next, click in the Top viewport; the omni light is displayed in the viewport and it is
automatically named as Omni001.

 
2. In the Modify tab, set the following parameters:
 
General Parameters rollout
Select the On check box in the Shadows area
 
Intensity/Color/Attenuation rollout
Set the value 0.6 in the Multiplier spinner
 
3. Select the Multiplier color swatch and modify the colors by setting the following parameters:



 
Red: 255 Green: 219 Red: 181
4. Align Omni001 in viewports, as shown in Figure 13-82.

Figure 13-82 The Omni001 light in viewports
 
Next, you need to create the target direct light in the scene to give the shadow effect.
 
5. Activate the Front viewport, choose the Zoom tool, and zoom out until the objects are displayed

about half of their original size.
 
6. Choose the Target Direct tool from Create > Lights > Standard > Object Type rollout in the

Command Panel. Move the cursor on the left side of the Front viewport; the shape of the cursor
changes. Next, press and hold the left mouse button to specify the location of the light and drag the
cursor near the front portion of wall001 to specify the target of the light. Release the left mouse
button; the light is displayed in all viewports and it is automatically named as Direct001.

 
7. Choose the Modify tab in the Command Panel; various rollouts to modify the target direct are

displayed to modify the target direct light.
 
8. Expand the General Parameters rollout and select the On check box in the Shadows area.
 
9. In the Directional Parameters rollout, select the Rectangle radio button and set the values in the

respective spinners as given below:
 
Hotspot/Beam: 84.0 Falloff/Field: 86.0
 
10. Expand the Atmospheres & Effects rollout and choose the Add button; the Add Atmosphere or

Effect dialog box is displayed. Select the Volume Light option and choose the OK button; the
Volume Light option is displayed in the text area of the Atmospheres & Effects rollout.

Next, you need to modify the parameters of the Volume Light.
 
11. Select the Volume Light option in the Atmospheres & Effects rollout and choose the Setup



button; the Environment and Effects dialog box is displayed. The Environment tab is chosen by
default in the Environment and Effects dialog box.

 
12. In the Atmosphere rollout, make sure the Volume Light option is selected in the Effects area.

Set the value 1.5 in the Density spinner of the Volume area in the Volume Light Parameters
rollout. Use the default values for other options and close the Environment and Effects dialog
box.

 

Note
You can also use different settings in the Volume Light Parameters rollout to give different effects
in the scene.
 
13. Align Direct001 light in the viewports to cover window, as shown in Figure 13-83.

 

Note
You can adjust the position of the Camera001 to view the scene with desired light effects.
 
Creating Background
In this section, you will create a background for the scene across the window.
 
1. Choose Rendering > Environment from the menu bar; the Environment and Effects dialog box is

displayed.
 
2. The Environment tab is chosen by default in the Environment and Effects dialog box. In the

Background area of the Common Parameters rollout, choose the Environment Map button that is
currently labeled as None; the Material/Map Browser dialog box is displayed.

 
3. Select the Bitmap map and choose the OK button; the Select Bitmap Image File dialog box is

displayed. As the project folder is already set, the images folder is displayed in the Look in drop-
down list of this dialog box. Select the CLOUDS4.jpg file and choose the Open button; the
selected image is displayed in the background after rendering. Close the Environment and Effects
dialog box.



Figure 13-83 Alignment of the Direct001 light in viewports
 

Saving and Rendering the Scene
 
1. Choose Save from the Application menu. Activate the Camera001 viewport.
 
2. Choose the Render Production tool in the Main Toolbar; the Rendered Frame window is

displayed, showing the final output of the scene, as shown in Figure 13-84.
 

3. Close this window.
 

Figure 13-84 The final output after rendering

Tutorial 3
In this tutorial, you will illuminate a night scene of a room using photometric lights, refer to Figure
13-85. (Expected time: 30 min)
 

 
The following steps are required to complete this tutorial:
 
a. Create the project folder.
b. Open the file.
c. Create the roof light.
d. Create wall lights.
e. Save and render the scene.
 



Creating the Project Folder
1. Create a project folder with the name c13_tut3 in the 3dsmax2015 folder, as discussed in Tutorial

1 of Chapter 2.
 
2. Open Windows Explorer and then browse to \Documents\c13_3dsmax_2015_tut. Next, copy all

jpeg files to \Documents\3dsmax2015\c13_tut3\sceneassets\images. Also, copy 1.IES file to
\Documents\3dsmax2015\c13_tut3\sceneassets\photometric.

 

Figure 13-85 The illuminated night scene of a room
 

Opening the File
1. Choose Open from the Application menu; the Open File dialog box is displayed. In this dialog

box, browse to the location \Documents\c13_3dsmax_2015_tut and select the c13_tut3_start.max
file from it. Choose the Open button to open the file, refer to Figure 13-86.

 
2. Choose Save As from the Application menu; the Save File As dialog box is displayed. Browse to

the location \Documents\3dsmax2015\c13_tut3\scenes. Save the file with the name
c13tut3.max at this location.

 
Creating the Roof Light
In this section, you will create the roof light by using the Free Light tool.
 
1. Choose the Maximize Viewport Toggle tool to view all the viewports and activate the Top

viewport. Choose Create > Lights in the Command Panel. By default, the Photometric option is
displayed in the drop-down list below the Lights button.

 
2. Choose the Free Light tool from the Object Type rollout; the Photometric Light Creation

message box is displayed, as shown in Figure 13-87. Next, choose Yes from this message box.
Also, various rollouts are displayed in the Command Panel.



Figure 13-86 The c13_tut3_start.max file
 

Figure 13-87 The Photometric Light Creation message box
 

3. Click at the center of the room; the free light is created with the name PhotometricLight001. Enter
rooflight in the Name and Color rollout.

 
4. Choose the Select and Move tool and align rooflight in the viewports, as shown in Figure 13-88.

 
Next, you will modify the shape of rooflight.
 
5. Choose the Modify tab in the Command Panel. Next, in the Emit Light from (Shape) area of the

Shape/Area Shadows rollout, select the Sphere option from the drop-down list; the shape of the
light changes in the viewport and the Radius spinner is displayed in the Emit Light from (Shape)
area. Also, the Shadow Samples drop-down list is added to the Rendering area located below it.

 
6. Set the value 85 in the Radius spinner to increase the spread of the light; the shape of rooflight is

modified, as shown in Figure 13-89.

Figure 13-88 The rooflight aligned in the viewports
 



Figure 13-89 The shape of rooflight changed
 

Next, you will modify the parameters of rooflight to lit the room with proper intensity, colors, and
shadows.

7. In the General Parameters rollout, make sure the On check box is selected in the Shadows area.
Next, select Ray Traced Shadows in the drop-down list below this check box.

 
8. Make sure the Uniform Spherical option is selected in the drop-down list located in the Light

Distribution (Type) area.
 
The Uniform Spherical option is used to spread light in all directions.
 
9. Select the radio button located near the Kelvin Spinner; the Kelvin spinner is activated.
 
10. Set the value 6372 in the Kelvin spinner; the color swatch located next to the Kelvin spinner is

changed to white. Next, choose the Filter Color color swatch located below it; the Color Selector:
Filter Color dialog box is displayed. In this dialog box, make sure the value in the Red, Green,
and Blue spinners is set to 255 and then choose the OK button to close the dialog box.

 

Note
The value in the Kelvin spinner and the color in the Filter Color color swatch together define the
color shade of the light being created. You can use different combinations of the spinner value and
color shade in the color swatch to achieve a variety of light color shades.

Next, you will set the intensity of rooflight.
 
11. In the Intensity area of the Intensity/Color/Attenuation rollout, select the lm radio button; the

value in the first spinner located below the lm radio button changes and displays the intensity of the
light in Lumen. Next, set the value 700 in this spinner; the intensity of the light is changed.

 
Now, you will render the scene to view the effect of modifying rooflight parameters in the scene.
 



12. Activate the Perspective viewport and adjust its view. Next, choose the Render Production tool
from the Main Toolbar; the rendered image is displayed, refer to Figure 13-90.

 
You will notice the grains in the rendered image. Next, you will remove grains in the image by using

higher shadow samples.
 
13. In the Rendering area of the Shape/Area Shadows rollout, select 256 from the Shadow Samples

drop-down list.
 

Note
If you select higher values for sampling shadows from the Shadow Samples drop-down list, the
quality of the render is improved but the rendering time also increases.
 
14. Render the Perspective viewport again, as discussed earlier. The rendered image is displayed,

refer to Figure 13-91.

Figure 13-90 The rendered image with grains
 

Figure 13-91 The rendered image without grains
 

Creating Wall Lights
In this section, you will create wall lights by using the Target Light tool. You will also use IES file
to achieve a specific light pattern.



 
1. Switch from the Left viewport to the Right viewport. Now, activate the Front viewport. Choose

Create > Lights in the Command Panel. Next, choose the Target Light tool from the Object
Type rollout; various rollouts are displayed in the Command Panel.

 
2. Click at a point and drag the cursor downward. Next, release the left mouse button; a target light is

created. In the Name and Color rollout, enter spot light1. Next, choose the Select and Move tool
and then select spot light1 and spot light1.Target. Now, align them in the viewports, as shown in
Figure 13-92.

Figure 13-92 The spot light1 and spot light1.Target aligned in the viewports
 

Next, you need to modify the parameters of spot light1.
 
3. Select spot light1 and then choose the Modify tab in the Command Panel. In the General Parameters

rollout, select the Photometric Web option in the drop-down list from the Light Distribution
(Type) area; a Distribution (Photometric Web) rollout is displayed in the Command Panel.

 
Now, you will use a standard photometric IES file to create a specific lighting pattern. These IES

files are standard files provided by light manufacturers and are available on the internet for free
download.

 
4. In the Emit Light from (Shape) area of the Shape/Area Shadows rollout, make sure the Point

option is selected in the drop-down list.

5. Choose the < Choose Photometric File > button from the Distribution (Photometric Web)
rollout; the Open a Photometric Web File dialog box is displayed. As the project folder is
already set, the photometric folder of this project is displayed in the Look in drop-down list. Next,
select the 1.ies file from this dialog box and then choose the Open button; label of the button is
replaced by the name of the selected file. Also, the lighting pattern is displayed in the window
located above this button. Next, set the value -38 in the Y Rotation spinner.

Next, you need to set the intensity and color of spot light1.
 
6. Select the radio button located near the Kelvin Spinner; the Kelvin spinner is activated.



 
7. Choose the Filter Color color swatch located below it; the Color Selector: Filter Color dialog

box is displayed. In this dialog box, set the value in the Red, Green, and Blue spinners as given
next:

 
Red: 164 Green: 165 Blue: 112
Choose the OK button to close the dialog box; the color in the Filter Color color swatch is changed.
 
8. In the Intensity area of the Intensity/Color/Attenuation rollout, select the lm radio button; the

value in the first spinner located below this radio button changes and displays the intensity of the
light in Lumen. Next, set the value 9 in this spinner; the intensity of the light is increased.

 
9. In the Far Attenuation area of the Intensity/Color/Attenuation rollout, select the Use and Show

check boxes. Next, set 10 and 34 in the Start and End spinners, respectively.
 
10. Activate the Perspective viewport. Next, choose the Render Production tool from the Main

Toolbar; the rendered image is displayed, refer to Figure 13-93.
 

Next, you will add glow to the source of spot light1.
 
11. Choose Rendering > Material Editor > Compact Material Editor from the menu bar; the

Material Editor dialog box is displayed. Select the empty slot in it and modify its name in the
Material Name text box to lamp dome material.

12. Choose the Material Type button that is labeled as Arch & Design; the Material /Map Browser
dialog box is displayed. Select Standard from the Materials > Standard rollouts and choose the
OK button; the Standard material is displayed in the Material Editor dialog box.

 
13. Select the Color check box in the Self-Illumination area of the Blinn Basic Parameters rollout.

Next, choose the Color color swatch and change its color to white.

14. Choose the Diffuse, Specular color swatches from the Blinn Basic Parameters rollout and
change its color to white.



Figure 13-93 The rendered image
 

15. Set the value 81 in the Specular Level spinner and 51 in the Glossiness spinner of the Blinn
Basic Parameters rollout.

 
16. Select lamp holder dome from the Scene Explorer. Next, choose the Assign Material to

Selection button from the Material Editor dialog box; the self illuminating material is applied to
lamp holder dome.

 
17. Choose the Render Production tool from the Main Toolbar; the rendered image is displayed, as

shown in Figure 13-94. You will notice glow at the source of spot light1.
 

18. Activate the Right viewport and select spot light1 and spot light1.Target. Next, press and hold
the SHIFT key and drag the cursor to lamp holder located at the left of spot light1. Release the left
mouse button; the Clone Options dialog box is displayed. In this dialog box, select the Copy radio
button. Set the value 2 in the Number of Copies spinner and choose the OK button; two copies of
spot light1 and spot light1.Target are created in the viewports. Next, choose the Select and Move
tool and align these lights in the viewports, as shown in Figure 13-95.

Figure 13-94 The rendered image



Figure 13-95 Copies of spot light1 and spot light1.Target aligned in the viewports
 

19. Assign the lamp dome material to lamp holder dome 001 and lamp holder dome 002 to add glow
at the source of copied spot lights.

 
20. Similarly, you can create copies of spot light1 and spot light1.Target and place them at the

remaining spot lights of the false ceiling. You need to assign the lamp dome material to remaining
lamp holder domes.

 
Saving and Rendering the Scene
I

 
1. Choose Save from the Application menu.

 
2. Activate the Perspective viewport. Next, choose the Render Production tool from the Main

Toolbar; the rendered image is displayed, refer to Figure 13-96.

Figure 13-96 The rendered image
 
 


